How do I mitigate IT vulnerabilities risk with LabTutor Server?

LabTutor Server uses the Apache Tomcat (version 6.3.32) server software and because LabTutor is not intended to be exposed to the internet, only internal networks, the risk of an attack is very low.  

You may mitigate risk by ensuring that:

  1. LabTutor Server is not exposed to the internet
  2. LabTutor Server is only accessed by trusted machines and trusted users on the local network

An upgrade of Tomcat version 6.3.32 is not recommended or supported.  There are several dependencies that are file location reliant.