×

System Requirements for ADInstruments Software


Current Software

Software Version windows Windows
LabChart 8
  • LabChart 8.0.10 or later requires Microsoft Windows 10, Microsoft Windows 8, 7, or Vista SP1 (32-bit and 64-bit editions)
  • Earlier versions of LabChart are not compatible with Windows 10 and require Microsoft Windows 8, 7, Vista SP1 (32-bit and 64-bit editions)
  • Microsoft .NET Framework 4 or later
  • Internet Explorer 8.0 or later
  • USB interface for operation with PowerLab
  • Minimum screen resolution of 1280 x 768 to support common projector settings

To view files in LabChart Online the minimum browser requirements are:

  • Google Chrome 24.0 or later
  • Mozilla Firefox 18.0 or later
  • Internet Explorer 9 or later
  • Safari 6 or later
LabChart Reader 8
  • Microsoft Windows 10, 8, 7, Vista SP1 or later
  • Microsoft .NET Framework 4.0
  • Internet Explorer 8.0 or later
LabChart 7
  • Windows 10 (32-bit and 64-bit editions) (7.3.8 or later)
  • Windows 8 (32-bit and 64-bit editions) (7.3.7 or later)
  • Windows 7 (32-bit and 64-bit editions) (7.0.3 or later)
  • Windows Vista SP1 (32-bit and 64-bit editions) or later
  • Microsoft .NET Framework 2.0 SP2 or 3.5 SP1 or later
LabChart Reader 7
  • Windows 8 (32-bit and 64-bit editions) (7.3.7 or later)
  • Windows 7 (32-bit and 64-bit editions) (7.0.3 or later)
  • Windows Vista SP1 (32-bit and 64-bit editions) or later
  • Microsoft .NET Framework 2.0 SP2 or 3.5 SP1 or later
LabTutor Server 4
  • Recommended: Windows Server 2008, Windows Server 2012, Windows 7 or Windows 8
  • Microsoft .NET Framework 2.0 SP2 or 3.5 SP1 or later
  • Microsoft Internet Explorer 9 recommended, IE7 minimum
  • Dedicated access of port 80, 443, and 8005 (with no other web services running e.g IIS or Apache)
  • Web access to adinstruments.com
  • Adobe Reader 8.0 or later for report PDFs

We also recommended that the server computer has the following specifications:

  • A dual core processor
  • 2GB RAM
  • A hard drive with enough free space to install experiments and hold user data
LabTutor Client 4
  • Windows 7, 8, 10, Vista SP1 or later
  • Microsoft .NET Framework 2.0 SP2 or 3.5 SP1 or later
  • Internet Explorer 9 recommended, IE7 minimum
  • Dual Core CPU recommended
  • 1 Gbps network connection to LabTutor Server recommended, 100Mbps minimum
  • Flash plugin for IE9 or later required for video and audio
  • 1-2GB of disk space
LabAuthor 4
  • Windows 7, 8, 10, Vista SP1 or later
  • Microsoft .NET Framework 2.0 SP2 or 3.5 SP1 or later
  • Internet Explorer 9 recommended, IE7 minimum
  • Dual Core CPU recommended
  • 50GB HDD (depending on the number of experiments installed)
  • Flash plugin for IE9 or later required for video and audio
GLP Server 5.6 Windows Windows Server 2008 or later, Windows 7, 8, Vista SP1 or later
Software Version mac Macintosh
LabChart 8 Mac
  • OS X v10.8 Mountain Lion or later (LabChart 8.1.1 or later is required for Mac OS X 10.11 El Capitan)

To view files in LabChart Online the minimum browser requirements are:

  • Google Chrome 24.0 or later
  • Mozilla Firefox 18.0 or later
  • Safari 6 or later
LabChart 7 Mac OS X 10.4 or later (LabChart 7.2.3 or later is required for Mac OS X 10.7 Lion)
LabChart Reader 7 (7.3 or later) Mac OS X 10.6 or later

Archived Software

Software Version windows Windows
LabChart 6 (6.1 or later) Windows Vista SP1 (32-bit and 64-bit editions) or later
Chart 5 (5.5.6) Windows Vista SP1 (32-bit and 64-bit editions ) or later
LabTutor (3.0 or later) Windows Vista SP1 or later and .NET 2.0 SP2 or .NET 3.5 SP1 and Internet Explorer 7 or later
LabAuthor (2.0.1 or later) Windows Vista SP1 or later and .NET 2.0 or .NET 3.5 SP1 and Internet Explorer 7 or later
Scope 3 (3.8.8 or later) Windows Vista SP1 (32-bit and 64-bit editions) or later
Software Version mac Macintosh
LabChart 6 Mac OS X 10.4 to 10.6 (LabChart 6 is not supported on Mac OS X 10.7 Lion)
Chart 5 Mac OS X 10.1 to 10.6 (Chart 5.5.6 is required for Mac OS X 10.5. Chart 5 is not compatible with Mac OS X 10.7 Lion)
Scope 4 (4.1.1 or later) Mac OS X 10.4 to 10.6 (Scope 4 is not compatible with Mac OS X 10.7 Lion)