What do I need to know before getting started with LabChart Lightning?

LabChart Lightning contains many new features, as well as improvements to familiar features found in LabChart 8. However, what remains the same is the simple workflow of plugging in your PowerLab and clicking ‘Start’ to begin sampling your data.  Below is a list of both new and improved features that can be found in LabChart Lightning as well as a video describing each of them.
 


New Features

Data Management

We have redesigned the concept of ‘files’ and have introduced projects and recordings. 
A project is a container for all of the resources used in a study, and a recording represents the trials and experiments that collect the data for the study. The ‘File’ menu can be used to manage multiple projects to represent multiple studies that are managed up in the ‘File’ menu.
‘Export LabChart Data’ can be used if you wish to continue your experiment in LabChart 8. If you would like to use your calculated data values in LabChart or another program, you should Export as a Text file. 
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWA

Project Management

Projects can add new recordings by selecting ‘New Recording’.
You can import your own LabChart data into the project by selecting ‘Import LabChart Data’ from the ‘File’ menu.
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000002eFI8

Themes

We provide the choice of Light and Dark themes that can be accessed under the ‘View’ menu.
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWF
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWK

Data Overview

We have created an overview that displays all of the data in the recording, including a viewport that highlights the data currently in Chart View. You can adjust the size of the viewport by scrolling with the mouse wheel or click and drag the mouse up and down. You can also move along the data with a mouse click and drag, as well as jump to areas of interest with a single click.
 

rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWP

Annotations

We have redefined ‘comments’ as annotations. They can be created for all channels or for one channel by double-clicking in the Chart View.
We can add more context in the Annotation Properties by giving a name, the exact location in the block, and adjust the placement of the annotation.
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWU

Regions

Another feature we have introduced are regions to save areas of interest for analysis. If you make a selection, you can click on the [+] button to create a region. Regions can be categorized by type, so regions of the same type can be referenced for analysis.
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWZ

Improved Features

Navigating your data

Channel settings can be accessed by clicking on the channel name. You can modify how the data is shown and adjust these settings.
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWe

You can interact with the channel header to adjust the y-axis. You can autoscale by double-clicking, adjust the scale with click and drag horizontally, and adjust the range with click and drag vertically.
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWj
If you go into the Chart View data you can adjust the x-axis by using the mouse wheel to zoom around a point of interest and shift key and mouse wheel to scroll along the data. Data readouts are displayed next to the mouse cursor.
 
rtaImage?eid=ka069000000Htsj&feoid=00N1r00000KN7O8&refid=0EM1r000001crWo

If you have any questions about LabChart Lightning and its use, please reach out to your local ADInstruments Technical Support Representatives.