Getting Started with LabChart Lightning

Getting Started with LabChart Lightning

  • 6 Apr 20

Welcome to LabChart Lightning! In this video we will give you a brief overview of the general layout of the software, as well as an introduction to some of the new features.

LabChart Lightning contains many new features, as well as improvements to familiar features. But what remains the same is the simple workflow of plugging in your PowerLab and clicking ‘Start’ to begin sampling your data.


New Features

Data Management
We have redesigned the concept of ‘files’ and have introduced projects and recordings. 

A project is a container for all of the resources used in a study, and a recording represents the trials and experiments that collect the data for the study. The ‘File’ menu can be used to manage multiple projects to represent multiple studies that are managed up in the ‘File’ menu.

Project Management
Add new recordings to your projects by selecting ‘New Recording’.

You can import your own LabChart data into the project by going to File → Import and selecting ‘Import Recording’ (Ctrl+I). Find out more about projects and recordings in LabChart Lightning »

Theming
We provide the choice of Light and Dark theming that can be accessed under the ‘View’ menu, or by using the shortcut Ctrl+Shift+H.

Data Overview
We have created an overview that displays all of the data in the recording, including a viewport that highlights the data currently in Chart View. You can adjust the size of the viewport by scrolling with the mouse wheel or click and drag the mouse up and down. You can also move along the data with a mouse click and drag, as well as jump to areas of interest with a single click.

Annotations
We have redefined ‘comments’ as annotations. They can be created for all channels or for one channel by double-clicking in the Chart View.

We can add more context in the Annotation Properties by giving a name, the exact location in the block, and adjust the placement of the annotation.

Regions
Another feature we have introduced are regions, which allow you to save areas of interest for analysis. If you make a selection, you can click on the [+] button to create a region. Regions can be categorized by type, so regions of the same type can be referenced for analysis.

Improved Features

Navigating your data
Channel settings can be accessed by clicking on the channel name. You can modify how the data is shown and adjust these settings.

You can interact with the channel header to adjust the y-axis. You can autoscale by double-clicking, adjust the scale with click and drag horizontally, and adjust the range with click and drag vertically.

If you go into the Chart View data you can adjust the x-axis by using the mouse wheel to zoom around a point of interest and shift key and mouse wheel to scroll along the data. Data readouts are displayed next to the mouse cursor.

If you have any questions not covered in this video or our other support material, please feel free to contact your nearest support representative - we’d be happy to help!

Enjoy!
The LabChart Team